SpringBoot v2.5.6 发布

:beetle: Bug 修复

  • 由于R2DBC优先于JDBC,当jOOQ的DSLContext不可用时,会出现误导性的故障分析。 #28379
  • 当启用懒惰初始化时,JMX端点不可用 #28371
  • JarFileWrapper可能导致许多FinalReferences,造成GC压力 #28356
  • 扁平化的VCAP_SERVICES属性在默认情况下是不被净化的 #28353
  • 后缀为 "d "的MeterValue没有被解析为定时器的持续时间 #28351
  • CachingOperationInvoker的缓存会消耗大量的堆空间 #28347
  • Devtools在内存R2DBC数据库和SQL初始化脚本中重启失败 #28345
  • ActiveMQ启动器依赖于org.apache.geronimo.specs:geronimo-j2ee-management_1.1_spec #28340
  • spring-boot-starter-oauth2-client对com.sun.mail:jakarta.mail有一个不必要的依赖。#28333
  • Layertools的提取并不保留最后修改和最后访问时间 #28190
  • 用IPv6地址配置spring.rabbitmq.addresses时出现NumberFormatException #28134
  • OpenMetrics的内容协商被破坏 #28130

:notebook_with_decorative_cover: 文档更新

  • 修正EnvironmentPostProcessor的类级javadoc中的错字 #28382
  • 移除关于Spring Integration的度量衡支持的过期信息 #28375
  • 更新文档,明确说明点符号的正确映射。 #28201
  • 第4.4节文件旋转提到了Log4j2的错误配置文件名称 #28193
  • 更新Javadoc的注释,提到使用构造函数绑定的类必须使用注解来启用。 #28171
  • 更加明确的是,当在@DataJpaTest之外使用@AutoConfigureTestEntityManager时,任何使用测试实体管理器的测试必须是@Transactional#28159

:hammer: 依赖升级

  • Upgrade to Dropwizard Metrics 4.1.26 #28280
  • Upgrade to Ehcache3 3.9.7 #28394
  • Upgrade to HttpCore5 5.1.2 #28281
  • Upgrade to Jaybird 4.0.4.java8 #28282
  • Upgrade to Jetty 9.4.44.v20210927 #28283
  • Upgrade to Lombok 1.18.22 #28284
  • Upgrade to Micrometer 1.7.5 #28242
  • Upgrade to MySQL 8.0.27 #28395
  • Upgrade to Netty 4.1.69.Final #28360
  • Upgrade to Netty tcNative 2.0.44.Final #28285
  • Upgrade to Postgresql 42.2.24 #28286
  • Upgrade to R2DBC Bom Arabba-SR11 #28287
  • Upgrade to Reactor 2020.0.12 #28240
  • Upgrade to SendGrid 4.7.6 #28396
  • Upgrade to Spring AMQP 2.3.11 #28245
  • Upgrade to Spring Data 2021.0.6 #28244
  • Upgrade to Spring Framework 5.3.12 #28241
  • Upgrade to Spring HATEOAS 1.3.5 #28243
  • Upgrade to Spring Integration 5.5.5 #28249
  • Upgrade to Spring Kafka 2.7.8 #28246
  • Upgrade to Spring Security 5.5.3 #28247
  • Upgrade to Spring Session 2021.0.3 #28248
  • Upgrade to Tomcat 9.0.54 #28288
  • Upgrade to Undertow 2.2.12.Final #28289
  • Upgrade to XmlUnit2 2.8.3 #28397

原文