SpringBoot v2.4.4 发布

:beetle: Bug 修复

  • 当SQLException不能被翻译时,JooqExceptionTranslator将null异常传递给jOOQ。
    #25717
  • 当配置了多个模式或数据脚本位置,但在一个位置上找不到资源时,你无法判断哪个位置有问题。 #25692
  • @ConfigurationProperties类的默认值在传递给Validator.validate(Object target, Errors errors)的Errors实例中不可见。#25614
  • EmbeddedDatabaseConnection#h2 不应指定主机名。 #25569
  • 如果没有spring-web,RSocket的EmbeddedServerAutoConfiguration就不会退缩。 #25555
  • 当从包含同一组属性的json文件中加载时,配置MetadataRepository不正确。 #25515
  • Layertools可以在目标路径之外提取条目。#25508
  • spring-boot:stop的默认分叉值不一致。 #25483
  • 将执行器和Jersey配置为过滤器时,应用程序无法启动。 #25449
  • 在Spring Boot 2.4中,@EntityScan不支持属性替换。 #25436
  • SpringApplication可以替换现有的默认属性源 #25408
  • Bootstrapper 的 intitialize 方法应该命名为 initialize #25400
  • 包含spring-boot-devtools会导致代理类的package-private getter返回null。#25367
  • 在classpath上使用devtools创建以ServerHttpSecurity为目标的Aspect时,启动失败。
    #19010

:notebook_with_decorative_cover: 文档

  • management.metrics.export.influx.db描述有误。 #25724
  • 修正ON_PARAM的javadoc,以准确描述其行为。 #25603
  • 修正README中的错别字 #25600
  • 支持Java 16的文档 #25527
  • 改进Mockito测试执行监听器的文档。#25513
  • 在参考文档中突出显示执行器API文档的链接。 #25510
  • 修正gradle插件文档中的属性名 #25454
  • 修正文档中的语法错误 #25411
  • 修正build-info目标描述中的文字错误。 #25385
  • 波兰语的HTTP客户端指标文档措辞 #25371
  • 记录DataSourceBuilder支持的DataSource实现。 #25333
  • 增加关于应用yml和属性文件优先级的注解 #25300
  • 文档如何将Docker秘密导入到configtree中。 #25095
  • 警告:使用"@PropertySource “或”@TestPropertySource "不能加载多文件属性文件。 #24945

:hammer: 依赖升级

  • Upgrade to AppEngine SDK 1.9.87 #25623
  • Upgrade to Byte Buddy 1.10.22 #25624
  • Upgrade to Dropwizard Metrics 4.1.18 #25625
  • Upgrade to Ehcache3 3.9.2 #25626
  • Upgrade to Hibernate 5.4.29.Final #25627
  • Upgrade to Infinispan 11.0.10.Final #25628
  • Upgrade to Jakarta Mail 1.6.6 #25629
  • Upgrade to Jetty 9.4.38.v20210224 #25461
  • Upgrade to Jetty Reactive HTTPClient 1.1.6 #25630
  • Upgrade to jOOQ 3.14.8 #25631
  • Upgrade to Kotlin 1.4.31 #25632
  • Upgrade to Kotlin Coroutines 1.4.3 #25719
  • Upgrade to Lettuce 6.0.3.RELEASE #25720
  • Upgrade to Maven Invoker Plugin 3.2.2 #25633
  • Upgrade to Micrometer 1.6.5 #25543
  • Upgrade to MongoDB 4.1.2 #25634
  • Upgrade to Netty 4.1.60.Final #25635
  • Upgrade to OAuth2 OIDC SDK 8.36.1 #25636
  • Upgrade to Postgresql 42.2.19 #25637
  • Upgrade to R2DBC Bom Arabba-SR9 #25638
  • Upgrade to Reactor 2020.0.5 #25539
  • Upgrade to Spring AMQP 2.3.6 #25647
  • Upgrade to Spring Batch 4.3.2 #25579
  • Upgrade to Spring Data 2020.0.6 #25547
  • Upgrade to Spring Framework 5.3.5 #25541
  • Upgrade to Spring HATEOAS 1.2.5 #25545
  • Upgrade to Spring Integration 5.4.5 #25646
  • Upgrade to Spring Kafka 2.6.7 #25578
  • Upgrade to Sun Mail 1.6.6 #25639
  • Upgrade to Tomcat 9.0.44 #25640
  • Upgrade to Undertow 2.2.5.Final #25641

信息来源