springboot2.x对redis版本有要求吗?

springboot2.x对redis版本有要求吗?求大佬给解答一下。如果有,不同版本的springboot对应的redis版本是什么呢?

springboot对redis的版本应该没啥要求。它也是使用的开源客户端JedisIettuce。然后对这些客户端进行了一个封装。提供了自己的一套api。

谢谢!

你可以通过修改Maven的依赖。来限制springboot使用的Redis客户端。只要是Redis的客户端支持,那么springboot肯定支持。

没有要求,不过springboot2.x默认使用的是lettuce来操纵redis,当然也可以切换jedis,但是经过我实际项目验证,还是没有Redisson好用,无论在功能上还是性能生,Redisson更好一些。